You are here

tvtvus website has changed again I think

66 posts / 0 new
Last post
frankabagnale3rd
Offline
frankabagnale3rd's picture
Donator
Joined: 2 years
Last seen: 2 weeks
ejohalj wrote:

I do still have some problem with this, I have version version V3.2.2.0 of Webgrabplus(Linux version), I also updated to the latest tvtv.us.ini, so I have"@Revision 8 - [21/09/2022] Mat8861*rewrite".
So the error I get is this:
( x/xx ) TVTV.US -- chan. (xmltv_id=CMT) -- mode Incremental
iiiiiii
Unable to update channel CMT
Generic syntax exception:
message:
no index page data received from CMT
unable to update channel, try again later
Existing guide data restored!
I would be happy to get a little help, thanks!!

Did you try these steps? http://www.webgrabplus.com/comment/30185#comment-30185

ejohalj
Offline
Donator
Joined: 4 years
Last seen: 3 days

Well, we were informed that adding the compression part was not necessary, but yes I tried only that part, and no it didnt work.

ejohalj
Offline
Donator
Joined: 4 years
Last seen: 3 days

I have tried several things, creating a new folder(using Linux) and run just two channels, but still getting the same issue, also tried to create a new xml list with:
< update>c2-CAN-0005972-X< /update>"

< channels>
< channel update="i" site="tvtv.ca" site_id="CAN-0005972-X" xmltv_id="BELL-OTTAWA">Channels-Ottawa< /channel>
< /channels>"

I get this message when trying to create a new xml file:
Job started at 22/09/2022 16:42:03
Checking License ..
For License request/update data, see WGLicense.log.txt
found: /home/pi/Downloads/.wg++/testing/tvtv.ca.ini -- Revision 05
encrypted in 'new (V3)' mode

!! SiteIni tvtv.ca.ini in channelfile creation mode !!!

processing /mnt/MEDIA_NAS/EPG/testing_Canada.xml ...
Found existing channel (xmltv_id=BELL-OTTAWA) in the config file
...

i=index .=same c=change g=gab r=replace n=new

Group (0) :
update requested for - 0 - out of - 1 - channels for 7 day(s)

Group (1) :
update requested for - 1 - out of - 1 - channels for 7 day(s)
( 1/1 ) TVTV.CA -- chan. (xmltv_id=BELL-OTTAWA) -- mode Channellist
pipipipipipipi
Unable to update channel BELL-OTTAWA
Generic syntax exception:
message:
no index page data received from BELL-OTTAWA
unable to update channel, try again later
No guide data to restore

Job finished at 22/09/2022 16:42:09 done in 6s

frankabagnale3rd
Offline
frankabagnale3rd's picture
Donator
Joined: 2 years
Last seen: 2 weeks
ejohalj wrote:

I have tried several things, creating a new folder(using Linux) and run just two channels, but still getting the same issue, also tried to create a new xml list with:
< update>c2-CAN-0005972-X< /update>"
< channels>
< channel update="i" site="tvtv.ca" site_id="CAN-0005972-X" xmltv_id="BELL-OTTAWA">Channels-Ottawa< /channel>
< /channels>"
I get this message when trying to create a new xml file:
Job started at 22/09/2022 16:42:03
Checking License ..
For License request/update data, see WGLicense.log.txt
found: /home/pi/Downloads/.wg++/testing/tvtv.ca.ini -- Revision 05
encrypted in 'new (V3)' mode
!! SiteIni tvtv.ca.ini in channelfile creation mode !!!
processing /mnt/MEDIA_NAS/EPG/testing_Canada.xml ...
Found existing channel (xmltv_id=BELL-OTTAWA) in the config file
...
i=index .=same c=change g=gab r=replace n=new
Group (0) :
update requested for - 0 - out of - 1 - channels for 7 day(s)
Group (1) :
update requested for - 1 - out of - 1 - channels for 7 day(s)
( 1/1 ) TVTV.CA -- chan. (xmltv_id=BELL-OTTAWA) -- mode Channellist
pipipipipipipi
Unable to update channel BELL-OTTAWA
Generic syntax exception:
message:
no index page data received from BELL-OTTAWA
unable to update channel, try again later
No guide data to restore
Job finished at 22/09/2022 16:42:09 done in 6s

I have several servers running WG and I have one that is not playing nice.So I was backing up the ~/.wg++ contents before I wiped it. Inside that backup was a folder just named '~'
I've seen it a thousand times and never bothered to look in it. When I did I found a bunch of old creation files that I thought were failing to be made. So you can look for that or any odd directory.

You can add your config and ini file with just your user info removed to this thread. I would say you could send them direct to me but I don't see a way to send messages.

frankabagnale3rd
Offline
frankabagnale3rd's picture
Donator
Joined: 2 years
Last seen: 2 weeks
Tw1zT3D247 wrote:

I get this error any ideas? I also updated to the latest tvtv.us.ini, so I have"@Revision 8 - [21/09/2022] Mat8861*rewrite".
error downloading page: The requested address is not valid in its context. (tvtv.us:443)

From what I understand at this point is you need to have .NET 5 framework for this version to work. On Windows open File Explorer and type this path in the bar C:\Windows\Microsoft.NET\Framework

You will see there which versions you have

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 18 hours

You need to update wg++, adding compression gzip is valid for old version like 3.2.0.
Updating wg++ solve all the problems, as it works for me, must work for you.

ejohalj
Offline
Donator
Joined: 4 years
Last seen: 3 days

Mat: I think I need some of your help. I have really tried everything here now, I have updated to several different versions, I also updated to the latest eval version(WebGrabPlus_V5.0.0.2_eval_install.zip) , even though I am not sure how to use it. It creates a folder called bin.net, and as I understood I should copy all the files from bin.net to bin. When I run, I still only get:

WebGrab+Plus/w MDB & REX Postprocess -- version V3.2.4.0
Running on: Unix 5.10.103.7
Environment: 4.0.30319.42000
Mono version: 6.8.0.105

No matter what I try with tvtvus or tvtvca I get the same error:
( 1/68 ) TVTV.CA -- chan. (xmltv_id=Disney Channel Canada HD) -- mode Incremental
iiiiiii
Unable to update channel Disney Channel Canada HD
Generic syntax exception:
message:
no index page data received from Disney Channel Canada HD
unable to update channel, try again later
Existing guide data restored!

And yes I am using the latest ini file that you posted. What can I do?

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 18 hours

WG++.net
you need to run the script ./run.net.sh or directly with path (Scrivania=Desktop)
root@ubuntu:/home/ubuntu/Scrivania/.wg++# dotnet /home/ubuntu/Scrivania/.wg++/bin.net/WebGrab+Plus.dll

TVTV:CA
Make sure you have latest wg++
unzip in robots folder the attached and rename it to tvtv.ca.robots (do not modify it, only rename it)
if you have linux chmod 644, in windows properties>check read only.
What i noticed is you need to have as many empty lines as you delete. Se attached robots (original) is made of 5 lines and need to remove the 2 disallow, in robots1 i end up with 5 lines 3 are empty but present.
If you have only 2 lines and no empty lines will not work (see robots_wrong).
After make it ready only and will work both windows and ubuntu.
Bye

dariofol
Offline
Donator
Joined: 3 years
Last seen: 1 week

Have you Try to use tvtv.us and change site in the webgrab config?

dariofol
Offline
Donator
Joined: 3 years
Last seen: 1 week
mat8861 wrote:

dariofol wrote:

mat8861 wrote:
will try to separate

I don't want to rush you but there is some news about missing tag of ini file?

can you post a sample of you need, I checked and seems fine.

im sorry Mat seem that only you reply in the forum.. I post several time request about the ini file and the subtitle TAG ... its possible the request or not?
i open a new thread to keep it separate from the other problem.
pls let me know something
thx as usual
dario.

pab24000
Offline
Donator
Joined: 2 months
Last seen: 2 months
frankabagnale3rd wrote:

I did this:
nano ~/.wg++/siteini.pack/USA/tvtv.us.ini
After all the change log and scanning instructions the first line looks like this:
**------------------------------------------------------------------------------------------------
site {url=tvtv.us|timezone=UTC|maxdays=7|cultureinfo=en-US|charset=UTF-8|episodesystem=onscreen|ratingsystem=US}
At the very beginning add compression=gzip|
It should now look like this:
**------------------------------------------------------------------------------------------------
site {compression=gzip|url=tvtv.us|timezone=UTC|maxdays=7|cultureinfo=en-US|charset=UTF-8|episodesystem=onscreen|ratingsystem=US}
My tvtv.us is scanning now as we speak. Hope this helps.

I spent about 8 hours trying different things to get my tvtv.us.ini to provide me a channel list... This was the step that fixed it.

I could get the broadcast list, but trying to scrape for the channel list to create the final xml was going nowhere until I made this simple edit to the .ini

Somebody who has rights to edit the tvtv.us.ini in github should make this change!

frankabagnale3rd
Offline
frankabagnale3rd's picture
Donator
Joined: 2 years
Last seen: 2 weeks

The updated version does have the fix. I think working without the edit on versions 4.2 and up

pab24000
Offline
Donator
Joined: 2 months
Last seen: 2 months

Well, I know the latest ini pulled from github didn't work on 3.2.0 without the edit. It could be it needs 4.2 or higher. I see that the latest stable release has just been incremented to 3.3. I'll see if it works on 3.3 without the edit. But if not, may be at least useful to make a note that the edit is necessary for versions under 4.2 since I'm sure there are many folks like me who use the stable releases only

pab24000
Offline
Donator
Joined: 2 months
Last seen: 2 months

Well, I know the latest ini pulled from github didn't work on 3.2.0 without the edit. It could be it needs 4.2 or higher. I see that the latest stable release has just been incremented to 3.3. I'll see if it works on 3.3 without the edit. But if not, may be at least useful to make a note that the edit is necessary for versions under 4.2 since I'm sure there are many folks like me who use the stable releases only

ejohalj
Offline
Donator
Joined: 4 years
Last seen: 3 days

mat8861, thanks for all the help, right now I got the tvtvus working, will try things with tvtvca, thanks again!

Pages

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl