You are here

Time confusuion

23 posts / 0 new
Last post
Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days
Time confusuion

Hello. I have been having issues with my EPG being incorrect. I have seen multiple solutions but some of them don't sound like good ideas, like modifying ini's.

Sky UK site shows this start time...

20:00

My guide.xml shows...

20210416190000 +0100

Other channels are correct though. Here is BBC Brit Norway

20210416210000 +0200

The show matches start time with 20:00 UK time. (So that is (21:00-200)+100?)

I'm not sure if this has anything to do with DST? It seems strange that some are correct and others are not.

I really don't want to start messing around with ini's, mainly because I have a script that checks for updates before running grabs, so any changes wouldn't stick.

Can anyone advise me please?

EDIT: Is it possible some sites are adjusting the times for my timezone?
tv.wp.pl for example, shows correct times (for me in BST) when I visit inside a web browser.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

just the opposite.
your epg software should adjust the time to your local time regardless of what time offeset epg data has.
what time offset the epg data is in shouldnt matter.
what u need figure out is if the epg or the stream is wrong and i have seen providers delay(timeshift) it to avoind buffering.

btw it has happened where a ini has a wrong timeoffset
i assume ur using multiple
so i dont think that the case here.
as some channel would be correct in epg.

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

I'm using sat, so straight from the source.

Like I said in my edit, some sites are adjusting the schedules for my time zone, not the time zone of the country of origin (the one listed in the ini). I wonder if this is the route of the issues?

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

so what timezone sat epg use?

there alot factors to consider.
paste a few epg data(not alot)
and ini u using.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

it cud be simply ini set to wrongtimezone...it happens
or it cud be more complex.

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

The EPG is not linked to sat time. The xmltv time is adjusted to local time... As far as I can tell.

This site is a good example of what I am talking about...
https://tv.wp.pl/

If you visit it will show your local time and the schedules are in your local time. But the ini is set to Europe/Warsaw

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

and whats ur timezone?
utc +/- xxxx
if its off that many hrs its incorrect then.
so change it(never reccommded unless u understand it)

poland right now utc +0200 i think,i dont keep track who does and doesnt obsever dst for europe.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

it show your local time as it gets ur local time from webbrowser when i visit and adjust it.
it dont mean the actual data is in same format.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

checked file i have and didnt test it as i not too much involved lately but i have timezone=UTC on site {xxx} line
cud explain ur prob.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

so imho thats ur issue.

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

site {url=tv.wp.pl|timezone=Europe/Warsaw|maxdays=7.1|cultureinfo=pl-PL|charset=utf-8|titlematchfactor=60|allowlastdayoverflow}

This is from the git. Unedited.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

change to timezone=UTC
and i sure u be good

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

Maybe that would work. But editing ini is bad? If there is problem, shouldn't git siteini be updated?

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

That site show programme starts at 22:40, xml shows start="20210416214000 +0200", software show 20:40

It seems software is working. My time zone now with DST is UTC+1

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

ur all good then.well mention to matt8861 to change timezone setting in ini.
thanks.

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

OK so it is ini problem. I wonder why no one else mentions it? I thought I had problem my side. There are many sites that are wrong for me. Tomorrow I will check more and make a list, now I know my software is working properly.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

so for u in epg it shows as 19:40?
just to make sure

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

no it is 20:40

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

there 100's ini.
we cannot check every one daily,just not possible.
we look when someone aske like urself.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

sorry my mistake.i still get confused caculating times yet to this day as it can be very confusing.
ur right.

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

no no that's fine. I just assumed it was my mistake.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

all good,we got it figured out and fixed.

Chris230291
Offline
Donator
Joined: 10 months
Last seen: 6 days

Thanks. I have forked the repo and I am going to do pull requests where I fix any incorrect timezones as I find them.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl