You are here

How to use WG 3.0 License

42 posts / 0 new
Last post
mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours
How to use WG 3.0 License

Starting WG++3.0.0 a license has been introduced.It simply requires to add a line to WebGrab++.config.xml. See doucumented WebGrab++.config.xml or follow this link http://webgrabplus.com/documentation/configuration/webgrabconfigxml#conf...
username= your username (case insensitive)
password= request it to "contact" http://webgrabplus.com/content/contact
email = email (the one used to register on the forum)

Attached a sample line to add to your WebGrab++.config

Attachments: 
boh73
Offline
Joined: 2 years
Last seen: 2 years

In your example you have only a "/>" at the end of the line. In the documentation you linked you can see it has to be "< /license>" (without the space after <).

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

I am waiting the site admin (Francis) to fix, because it won't change or add slash with >. Example is anyway attached in documented file (attached pic).

Attachments: 
oliroe
Offline
Joined: 3 years
Last seen: 2 years

Is there any possibility of adding a license for a greater period than 1 year i.e. a lifetime or 5 year license.
Personally I like my software to be as hands off as possible and don't want to think about this every 12 months.

Just a thought, thanks

HIMANEN
Offline
Donator
Joined: 2 years
Last seen: 1 month

i updated to 3.0.3 but its complaining something about the license:

] WebGrab+Plus/w MDB & REX Postprocess -- version V3.0.3.0
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 02/06/2020 00:45:29
[ Debug ]
[ Debug ] Running on: Microsoft Windows NT 6.2.9200.0
[ Debug ] Environment: 4.0.30319.42000
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ Debug ] Reading config file: C:\Users\himanen\AppData\Local\WebGrab+Plus\WebGrab++.config.xml
[ Info ] Checking License ..
[ Info ] For License request/update data, see WGLicense.log.txt
[ Debug ]
[ Info ] found: C:\Users\himanen\AppData\Local\WebGrab+Plus\siteini.pack\Sweden\tv.nu.ini -- Revision 11
[ Debug ]
[ Info ] found: C:\Users\himanen\AppData\Local\WebGrab+Plus\siteini.pack\International\streamingtvguides.com.E.ini -- Revision 00
[ Info ] encrypted in 'legacy (V2)' mode
[ Debug ] xmltv input file - e:\epg\guide.xml - found

Wglicense.log says:

License request/update
[ Info ] Username 'HIMANEN'
[ Info ] Custom License status : 'True'
[ Info ] The program will run with performance settings : 'custom'
[ Info ] License check .. done
[ ]
[ ] Actual settings of the custom license :
[ ]
[ ] License started on :2020/05/09
[ ] License will expire on :2021/04/19

is all ok or ???

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

yes looks ok

sbonkov
Offline
Has donated long time ago
Joined: 5 years
Last seen: 11 months

I decided to try the new Webgrab++ version.
I entered the license as described on the site.
And then I got a lot "Cannot grab from , siteini blocked due to a license restriction" wtf
I decided to use one of the donation section files.
and i found i can't use it because:
I only want to use the titles.
perhaps the description, if it is short.
I have to do many translations of the titles and possibly the description like:
index_title.modify {replace|Fudbal|Футбол}
etc.
but how do i do that as the whole file is encrypted and I can only change the time zone.
And "Cannot grab from , siteini blocked due to a license restriction" wtf :D
So this whole ini section is unusable for me.
Anyway. I'm back to the old Webgrab version.
I just wanted to share my experiences with you :D

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

try to force license so it update(see picture)

Attachments: 
sbonkov
Offline
Has donated long time ago
Joined: 5 years
Last seen: 11 months

Thanks for the help, but I decided to stay with the old version. As I mentioned above, these encrypted files are not for me.
I just made an ini file for the new channels that interested me:
http://www.webgrabplus.com/content/mojtvnet

Graburrz
Offline
Donator
Joined: 5 years
Last seen: 1 week

Not being the brightest bulb in the room, I upgraded to v3.1 on my Win10 system and I'm having problems configuring the code in my config file. I got the License pass code from my forum user profile and added my forum username and email address I use to log on to the 'Default' code":

<license wg-username="username" registered-email="forum email-address" password="password"></license>

But I'm having problems with the <!-- Set Username, email (used to register on the forum), password --> data to place in between. Is that section really necessary?

I tried just putting an f in between as mat8861 suggested in his force_license1_7.png above with no success: <license ...>f</license>

And I tried copying the username, registered-email, and license password from the (license) code to that middle code:

<!-- Set [Username used in (license)], [email used in (license)], [password used in (license)] -->

But WG still throws an error. I'll attach the log file. A friend set it up for me a long time ago, Maybe someone can spot a problem in it. Without the license line added, WG does run, but throws that error:

[Warning ] Number of allowed siteini's 2 for license 'default' reached

EDIT: I had some success by formatting the license code exactly as it appeared in the license1.png mat8861 posted above (I'll attach it again here), and placing it below the <settings> tag (duh!):

<license wg-username="username" registered-email="forum email-address" password="password" />

But now the log file only reports allowed siteini's as 3 instead of the previous 2:

[Warning ] Number of allowed siteini's 3 for license 'registered_user' reached.

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

Sorry that is old. Look at current sample here https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/site...

But your problem above is something wrong in config...so use the sample in siteini.pack and change license with your data

Graburrz
Offline
Donator
Joined: 5 years
Last seen: 1 week
mat8861 wrote:

Sorry that is old. Look at current sample here https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/site...
But your problem above is something wrong in config...so use the sample in siteini.pack and change license with your data

Oh... So you're saying the whole format of the header in my WebGrab++.config.xml is old. Yes, it's at least 3 years old. Do I have that right mat8861? I'll have at making a new one based on the WebGrab++.config.example.xml that was installed with v3.1 then, not on the one in the Github link you posted... right? Thanks.

Graburrz
Offline
Donator
Joined: 5 years
Last seen: 1 week

Most of my old config header was the same as what's in the new example config mat8861. But I pasted the example header over my old one, and tweaked the settings for each tag except for <decryptkey> which I left disabled. I'm not quite sure what <decryptkey> is for or if I need something in there. But I'm still getting the warning of allowed siteini's being 3 when I run WG. Will attach what I have for the header.

So I changed the license code to force it, but it had no effect:

<license wg-username="myxxxxxxxx" registered-email="myxxxxxxxx@xxxx.com" password="myxxxxxxxx">f</license>

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours
Graburrz wrote:

Most of my old config header was the same as what's in the new example config mat8861. But I pasted the example header over my old one, and tweaked the settings for each tag except for <decryptkey> which I left disabled. I'm not quite sure what <decryptkey> is for or if I need something in there. But I'm still getting the warning of allowed siteini's being 3 when I run WG. Will attach what I have for the header.

you need to enable the license https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/site...
the decrypt key is used to allow EK siteini if you become donator.

Graburrz
Offline
Donator
Joined: 5 years
Last seen: 1 week

I think I have the license properly enabled if you look at the attachment in my last post. I just put myxxxxx in place of my actual user info:

<license wg-username="myxxxxxxxx" registered-email="myxxxxxxxx@xxxx.com" password="myxxxxxxxx" />

And it did up my allowed siteini's from 2 to 3

Graburrz
Offline
Donator
Joined: 5 years
Last seen: 1 week

So after reading some forum posts and reading the WGLicense.log.txt in the new v3.1 folder, it looks like I'll need to make a donation in order to be able to have all of my 10 siteinis and 285 channels function in v3.1. Is that right?

I'm seeing these license types listed in the GLicense.log.txt: default, donator_license, donator, registered_user, un_registrd_user, developer. Each with it's own set of limits. With my numbers does this mean I'll need to donate as a developer or remove 35 channels and apply for a donator_license?

I also used to have postprocess set to mdb, and it looks like I'll need to make one of those 2 donations to enable it again... yes? I have to confess I never really understood why my friend set that up, or what exactly it accomplishes.

It looks like the basic 'Donator' badge starts at 5€ for 1 year, and that I need to contact an admin for how much the other licenses will require, yes? Or might there still be something I'm missing in configuring the license in the WG config as I've described above that could get me up and running with my current status?

Thanks for the feedback. :)

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours
Graburrz wrote:

So after reading some forum posts and reading the WGLicense.log.txt in the new v3.1 folder, it looks like I'll need to make a donation in order to be able to have all of my 10 siteinis and 285 channels function in v3.1. Is that right?
I'm seeing these license types listed in the GLicense.log.txt: default, donator_license, donator, registered_user, un_registrd_user, developer. Each with it's own set of limits. With my numbers does this mean I'll need to donate as a developer or remove 35 channels and apply for a donator_license?
I also used to have postprocess set to mdb, and it looks like I'll need to make one of those 2 donations to enable it again... yes? I have to confess I never really understood why my friend set that up, or what exactly it accomplishes.
It looks like the basic 'Donator' badge starts at 5€ for 1 year, and that I need to contact an admin for how much the other licenses will require, yes? Or might there still be something I'm missing in configuring the license in the WG config as I've described above that could get me up and running with my current status?
Thanks for the feedback. :)

To get (for me) a decent set-up is a donator_license of 5 euro = 250 channels and 15 siteini enabled, with 2 hardware id,mdb and rex enabled. You can then donate 10 euro by default is 2 year donator member, but you can send a message to authors and ask them to make 500 channels for 1 year. Becoming donator (5 euro) you also access donator area, where there the keys for EK siteini, except 3 siteini multi country or with lots of channels like mi.tv, movistarplay and jio (Latin America and India).
Extra donations for :
each 250 channels extra 5€
each 5 siteini's extra 5€
2 computers limit removed 20€
Other options on request ..option is --> contact the authors http://www.webgrabplus.com/content/contact

Graburrz
Offline
Donator
Joined: 5 years
Last seen: 1 week
mat8861 wrote:

To get (for me) a decent set-up is a donator_license of 5 euro = 250 channels and 15 siteini enabled, with 2 hardware id,mdb and rex enabled. You can then donate 10 euro by default is 2 year donator member, but you can send a message to authors and ask them to make 500 channels for 1 year. Becoming donator (5 euro) you also access donator area, where there the keys for EK siteini, except 3 siteini multi country or with lots of channels like mi.tv, movistarplay and jio (Latin America and India).
Extra donations for :
each 250 channels extra 5€
each 5 siteini's extra 5€
2 computers limit removed 20€
Other options on request ..option is --> contact the authors http://www.webgrabplus.com/content/contact

Thank you so very much for laying out those details mat8861. I'm more than happy to support the work of all the good people behind the scenes here. I went ahead and made a donation of 10€, 5€ for the donator_license you mention, and another 5€ hopefully for 250 extra channels if I'm reading your post correctly. Meanwhile I still have a Win7 system running a v2.1.5 beta, but am looking forward to data from some channels that require v3.1. :)

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

Ok, notify authors of what you want, as by default it assign 2 year membership with 10 euro.

Graburrz
Offline
Donator
Joined: 5 years
Last seen: 1 week
mat8861 wrote:

Ok, notify authors of what you want, as by default it assign 2 year membership with 10 euro.

In the Paypal payment process I did add a comment stating I wanted 5€ of the 10€ to be for 1 year for what you had suggested: donator_license, 250 channels, 15 siteini, 2 hardware id, mdb and rex. And the other 5€ was for an extra 250 channels. But I'll go ahead and E-mail WebGrab+Plus from the Contact page and reconfirm all that. Thanks Mat.

Floyd
Offline
Donator
Joined: 2 years
Last seen: 1 week

In addition to support, what version 3.1 has better than older versions?

stelin
Offline
Donator
Joined: 2 years
Last seen: 2 years

howto activate the donation licence

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours
89025032
Offline
Donator
Joined: 1 year
Last seen: 1 year

Hello!
I became a donor and I cannot update the license. I already did as informed in the site https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/site... and still informs in the log as "default".

Attachments: 
Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 10 hours

do a force lisence update as it says on the home page for V3.1

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

Grateful to answer, but I already did it and I can't activate my license.
The page v31, is different with the informed in the https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/site.... At the end of the line "password =" 123456 "> f " there is "-->". If I withdraw, the log reports an error on line 18 and if I post it, it does not update.

EDIT DO NOT POST KEYS !!

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 10 hours

your lisence like is disabled.
remove the !-- from the beginning and the -- at the end.
also for you password view your account on the forums and u will find ur own unique one.

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

As blackbear said remove extra characters. Sample here https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/site... or in documention

Roby
Offline
Donator
Joined: 5 years
Last seen: 1 year

I get the following errors

root@osmc:~# cd /var/spool/hts/wg++
root@osmc:/var/spool/hts/wg++# ./run.sh

WebGrab+Plus/w MDB & REX Postprocess -- version V3.1.0.0

Jan van Straaten
Francis De Paemeleere

thanks to Paul Weterings and all the contributing users
--------------------------------------------------------------------------------

Job started at 04/09/2020 13:30:21
Checking License ..
Job finished at 04/09/2020 13:30:25 done in 4s

Could not load file or assembly or one of its dependencies.

at WG.common.azure.Azure_Access.  () [0x00016] in :0
at WG.common.azure.Azure_Access..ctor () [0x00006] in :0
at  .–..ctor (System.Collections.Generic.Dictionary`2[TKey,TValue] , System.Boolean , System.Boolean ) [0x004c2] in <896f87e576a8482c8f603908a14ec73f>:0
at  . ..ctor (System.String ) [0x00989] in <896f87e576a8482c8f603908a14ec73f>:0
Unhandled Exception
For detailed info, see log file /var/spool/hts/wg++/./WGLicense.log.txt
Execution stopped
root@osmc:/var/spool/hts/wg++#

And how can i configrue WebGrab++.config.xml for Albania albepg

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

mono version > 5.0
https://www.mono-project.com/download/stable/
Config
https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/site...
set your licence/password (in your profile see license password) and add channels

Roby
Offline
Donator
Joined: 5 years
Last seen: 1 year

what should I enter here Albania albepg

sorry doppel post

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours
Roby
Offline
Donator
Joined: 5 years
Last seen: 1 year

and here what do I have to enter

Roby
Offline
Donator
Joined: 5 years
Last seen: 1 year

i have donated 6 euro but am still a default user

[ ] WebGrab++ license request and update log
[ ] 2020/09/04 15:55
[ ]
[Warning ] No License request in WebGrab++.config.xml
[ Info ] Consider to add a license request , like this:
[ Info ]
[ Info ] The program will run with performance settings : 'default'
[ Info ] License check .. done

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours
Roby wrote:

i have donated 6 euro but am still a default user
[ ] WebGrab++ license request and update log
[ ] 2020/09/04 15:55
[ ]
[Warning ] No License request in WebGrab++.config.xml
[ Info ] Consider to add a license request , like this:
[ Info ]
[ Info ] The program will run with performance settings : 'default'
[ Info ] License check .. done

read http://www.webgrabplus.com/faq#faq_4767

racinis
Offline
Donator
Joined: 2 years
Last seen: 1 year

[Error ] Azure userfile racinis.xml is corrupt!!
[Error ] Contact our support by mail or forum!!

I am getting this error could not understand problem?

Doktor-X
Offline
Joined: 1 year
Last seen: 1 year

why i dont have register licence

[ Info ] License request/update
[ Info ] Username 'Doktor-X'
[Warning ] A previous record dd 2021/04/12 for un_registered user 'Doktor-X' found
[Warning ] Correct the username in the license request :
[ Info ]
[ Info ] The program will run with performance settings : 'un_registered_user'
[ Info ] License check .. done

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours
Doktor-X wrote:

why i dont have register licence
[ Info ] License request/update
[ Info ] Username 'Doktor-X'
[Warning ] A previous record dd 2021/04/12 for un_registered user 'Doktor-X' found
[Warning ] Correct the username in the license request :
[ Info ]
[ Info ] The program will run with performance settings : 'un_registered_user'
[ Info ] License check .. done

Did you add license data ?

Doktor-X
Offline
Joined: 1 year
Last seen: 1 year

And this licence data is? If its my username email and code from my profile page then i did

after deleting hidden licence folder and runing program again i get

License request/update
[ Info ] Username 'Doktor-X'
[ Info ] License status : 'False'
[ Info ] Next update, first run after : 2021/04/13 23:51
[ Info ] The program will run with performance settings : 'registered_user'
[ Info ] License check .. done

what this License status : 'False' meen

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

Correct, license is active as registred user, if you would become a donator then is activated as donator and you can run also siteini encrypted up to 15 and up to 250 channels.
if you look at WGLicense.log.txt you will understand what you can run.

webtv
Offline
Donator
Joined: 1 year
Last seen: 2 months

I just installed Windows7 and installed Webgrab + again.
I get the following error:
[] WebGrab ++ license request and update log
[] 2021/06/15 19:59
[Info] Program update available !! - Version 3.1.8 @http: //www.webgrabplus.com/download/sw/v3.1.8
[]
[Info] License request / update
[Info] Username 'webtv'
[] Job finished at 06/15/2021 7:59:40 PM done in 1s
[Critical]
The root level data is invalid. line 1, position 1.
[Critical]
at System.Xml.XmlTextReaderImpl.Throw (Exception e)
at System.Xml.XmlTextReaderImpl.Throw (String res, String arg)
at System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace ()
in System.Xml.XmlTextReaderImpl.ParseDocumentContent ()
in System.Xml.XmlTextReaderImpl.Read ()
at System.Xml.XmlLoader.Load (XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load (XmlReader reader)
at System.Xml.XmlDocument.LoadXml (String xml)
en .– .. ctor (Dictionary`2, Boolean, Boolean)
on . ..ctor (String)
on .-. (String [])
[Critical] Unhandled Exception
[Critical] For detailed info, see log file C: \ Users \ Administrator \ AppData \ Local \ WebGrab + Plus \ WGLicense.log.txt
[Critical] Execution stopped

How can I solve that?

Thanks

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 12 hours

upgrade wg to 3.1.8 and run force license update http://webgrabplus.com/faq#faq_4767

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl