You are here

Another timeshift question

16 posts / 0 new
Last post
Uthall
Offline
Donator
Joined: 4 years
Last seen: 3 weeks
Another timeshift question

Hi There,

Ok i have tvguide.com running on a server in the US. The siteini defaults to UTC, and all the programs are -5 in the xml.

I run the same siteini on a France server, and all the programs are 6 hours out

USA server
programme start="20210213190000 -0500" stop="20210213193000 -0500" channel="CBS KTVT DAL US"

FR server
programme start="20210214010000 -0500" stop="20210214013000 -0500" channel="CBS KTVT DAL US"

Why would this be?

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

the site ini cant be in UTC,if it was you would see +0000 instead of -0500
check the timezone= setting on the site {xxx} line.
are you using the one posted here in the forums(i think its been added to siteini.pack also)

* @Revision 18 - [23/01/2021] Blackbear199
* - showsplit fix for null title shows
* - change start/stop to regex

http://webgrabplus.com/content/tvguidecom-usa-stopped-working-no-new-dat...
post #6

Uthall
Offline
Donator
Joined: 4 years
Last seen: 3 weeks

Yep thats the siteini im using for sure

My first line is

site {url=tvguide.com|timezone=UTC|maxdays=13|cultureinfo=en-US|charset=UTF-8|titlematchfactor=90}

defn getting -5 with that.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

check ur wg log
it will show the path to the tvguide.com ini being used.
its impossible for it to change to -0500 when its set to UTC

Uthall
Offline
Donator
Joined: 4 years
Last seen: 3 weeks

Sorry im a numpty.

Im using a combo of tvguide.com, streamingtvguides.com, and tvpassport.com

The latter two were set to US cities and not utc.

Would setting them to UTC fix the issue?

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

no.
they are both set to local times of their server.
the ini creator sets the timezone and users shouldnt edit it unless they know what they are doing.
you will make things worse by changing it.

the question is does your epg viewer support the timeoffset?
media portal for example doesnt(it expects all epg to be in users local time).
what are you viewing your epg with?

Uthall
Offline
Donator
Joined: 4 years
Last seen: 3 weeks

Well ive confirmed that the channels with issues are from tvpassport.com

The below are from the 2 different servers. As you can see the entries give different results using the same siteine using the current set timezones. These entries should be exactly the same regardless of server location right?

The difference is exactly like 6 hours....the difference between -5 (US) and +1 (FR)

USA server
programme start="20210213190000 -0500" stop="20210213193000 -0500" channel="CBS KTVT DAL US"

FR server
programme start="20210214010000 -0500" stop="20210214013000 -0500" channel="CBS KTVT DAL US"

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

does this match the stream,its tvpassport

Attachments: 
Uthall
Offline
Donator
Joined: 4 years
Last seen: 3 weeks

The USA string is correct (US Server), the FR string (FR server) is 6 hours ahead and wrong.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

exactly my point.
there are alot of factors in timezone correction.
the epg viewing software should automatically adjust the time to use uses local time so it displays correctly.
this is all based on timezone in guide.xml and timezone of user,its a rather complicated issue.
see the faq section at the top of the forums,its explains all this.
it shouldnt matter where u grab the epg data from.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

i have no idea why your getting diff results based on where the server is.
both should get the exact same thing.
did u check the timezone setting on your france server?

Uthall
Offline
Donator
Joined: 4 years
Last seen: 3 weeks

Server A (US)
Time zone: Etc/GMT-0 (GMT, +0000)

Server B (FR)
Time zone: Etc/UTC (UTC, +0000)

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

talked to mat8861
it may be a ini issue

Uthall
Offline
Donator
Joined: 4 years
Last seen: 3 weeks

@mat8861 can you help?

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 1 day

you have 2 option
1. test france srv with Europe/Paris
2. post-process with xmltv modify https://github.com/SilentButeo2/webgrabplus-siteinipack/tree/master/post...

alucca
Offline
Joined: 1 year
Last seen: 1 year

The two time zones are not apart, so you have to set the same time zone or set the same base time\
mapquest driving directions

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl