You are here

Error about "Current culture"? and time parsing

8 posts / 0 new
Last post
titovich
Offline
titovich's picture
Joined: 10 months
Last seen: 10 months
Error about "Current culture"? and time parsing

HI everybody, sorry for my english, it's not my native language.

I download EPG for many years from my spanish providers (from Spain). I haven't got any problems till today.
Today when the soft was downloading the EPG as always, it prints an error that i don't understand.

The error is....

"[ Debug ]
[ Info ] ( 124/295 ) XXXXXXX.COM -- chan. (xmltv_id=XXX2 HD) -- mode Incremental
[Warning ] no robots data found
[Warning ] skipped robots check
[ Debug ] skipped : show that happened before 'today' @ 18/07/2023 22:30
[Error ] Unable to update channel XXX2 HD
[Critical] Generic syntax exception:
[Critical] message:
[Error ] Current culture: en-GB
[Error ] time parsing error : No se puede reconocer la cadena como valor DateTime válido.
[Error ] nextstartdatetime time scrubbed :
[Error ] computer date/time format: 19/07/2023 10:27:59
[ Info ] Existing guide data restored!"

I have hidden the name of the provider and the channel but it's always the same with all the channels of this provider and it still works fine with other providers .
This had never happened until today.
What could be the reason for this to happen?
Can anybody help me?
Thanks.

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 7 hours

please post WebGrab++.log.txt, WebGrab++.config.xml and the siteini so we can check

titovich
Offline
titovich's picture
Joined: 10 months
Last seen: 10 months

Thanks mate
;)

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 7 hours

you have a channel that doesn't exsist that 's why is giving error

titovich
Offline
titovich's picture
Joined: 10 months
Last seen: 10 months

OK, thanks, I only added a channel, before it starts to fail.....
MY line says BOM CINE perhaps this is the error because in the .ini you has put it says BOMCINE (BOM CINE vs BOMCINE) right, I'll fix it and try again, thanks again :)

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 7 hours

Actually your log is full of errors, many due to non exsisting channels, many others due to old version of siteini.
My suggestion is to update both siteini.pack and webgrab.

titovich
Offline
titovich's picture
Joined: 10 months
Last seen: 10 months

Thank you very much for your interest, but the truth is that it always went well for me until I added the line of the BOM channel (BOMCINE) from there, all the euskaltel channels began to fail.
How do I download the epg on odd days, tomorrow I will report the result after fixing the BOMCINE line. If the error is repeated I will try to update the ini file (although it is not complete, all the +2 channels are missing) and also the webgrab.
One last question....is the latest version of webgrab a paid version? I ask because I don't know, I wouldn't mind paying for it. How should I update it?
Thank you very much again.
;)

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 7 hours

yes latest versions have restrictions, that can be removed with a donation of 5 euro for 1 year (250 channel) if you need more like 500 channels donate 10 euro

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl