You are here

What am i doing wrong? please help.

21 posts / 0 new
Last post
jimbop
Offline
Donator
Joined: 3 months
Last seen: 1 month
What am i doing wrong? please help.

Hi,
Been on this all day. Seems simple enough....copy & paste over the dummy line, which i do.

But running the prog does nothing!

I'm using windows 10 and webgrab 4.2.2.0.

My xml file looks ok i think.

Attached config file in case i've done something stupid!

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 15 hours

You need to add your license see https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/site...
change with your username, the license password (in your user panel), the email used to register on the forum.
Please be aware that without donation you will get the minimum of data (see the license log file after you run the first time) i think also the encrypted will not run.
If you don't get at least titles post your WebGrab++.log.txt

jimbop
Offline
Donator
Joined: 3 months
Last seen: 1 month

Done that.
""
Obviously blanked my password....no log file...nothing?
This is baffling me.
Edit: tried to paste line!! wont let me.

jimbop
Offline
Donator
Joined: 3 months
Last seen: 1 month

Ahh installed 3.2 and it now works!

nilvaldoloureiro
Offline
Donator
Joined: 1 year
Last seen: 3 weeks

I also tried updating to version 4.2, it doesn't run. I went back to version 3.2.3.1 which works great.

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 15 hours

version 4.2 needs dotnet installed.

nilvaldoloureiro
Offline
Donator
Joined: 1 year
Last seen: 3 weeks

Installing WebGrab 4.2.2.0:
1. I saved directories, packs and scripts from WebGrab 3.2.3.1;
2. I downloaded .NET5 using link https://dotnet.microsoft.com/en-us/download/dotnet/5.0;
3. Installed .NET5;
4. I uninstalled WebGrab 3.2.3.1;
5. Installed WebGrab 4.2.2.0;
6. I restored packs and scripts used in WebGrab 3.2.3.1, including the "Licence" directory (hidden in C:\Users\userx\AppData\Local\WebGrab+Plus) and the "WebGrab++.config.xml" file, where we have data of the user password.

It worked. Now testing if it generated EPG correctly.

Thanks for the .NET5 tip.

jksmurf
Offline
jksmurf's picture
Donator
Joined: 9 years
Last seen: 1 month

That link in (2) to doNET 5 throws an error; seems like dotNET 5 is on the way out (End of support May 10, 2022, see https://dotnet.microsoft.com/en-us/download/dotnet)

Will installing dotNET 6 also install dotNET 5 (or will it run on dotNET 6 anyway)?

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 3 hours

https://dotnet.microsoft.com/en-us/download/dotnet
click on out of support versions, you will find 5.0
webgrab wont work with 6.0

jksmurf
Offline
jksmurf's picture
Donator
Joined: 9 years
Last seen: 1 month

Thanks, is x64 version supported please?

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 3 hours

yes
https://dotnet.microsoft.com/en-us/download/dotnet/5.0
you dont need to install everything,just the .NET Runtime 5.0.17

jksmurf
Offline
jksmurf's picture
Donator
Joined: 9 years
Last seen: 1 month

Thanks. I tried (separately) the x64 and x86 versions. Did not work for me. Did not start the session, no log recorded.
Tried uninstalling 3.2.3 then installing 4.2, replacing config and Licence. Did not work for me.
Went back to 3.2.3; works again. Will try again sometime once more folks have ironed out install issues.

k.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 3 hours

your not proving much info,like what OS your using.

jksmurf
Offline
jksmurf's picture
Donator
Joined: 9 years
Last seen: 1 month
Blackbear199 wrote:

your not proving much info,like what OS your using.

Apologies, I'm on Windows 11 but I honestly couldn't think of anything else you don't know. I don't have a log so I can't give you any further info than that, unless you can point me to somewhere which does do some other logging?

p.s. I did not install it in the default dir, but here: C:\Program Files (x86)\WebGrabPlus

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 3 hours

i dont really.
i assume ur using run.net.exe(i think its called for for dotnet versions)
also u can have both installed
4.x and 3.x

jksmurf
Offline
jksmurf's picture
Donator
Joined: 9 years
Last seen: 1 month

I'm sorry I do not know what that is. I just installed the dotNET 5 runtime like you recommended above.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 3 hours

after u install V4.x
its doesnt use the same run shortcut that 3.x uses
i think it may be called run.net(shortcut)
i rarely use windows version,i am a linux guy.
and i think program files (x86)\WebGrab+Plus is the install directory for the exe files.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 3 hours

btw functional wise there no difference between 4.x and 3.x versions.
they are compiled from exact same source code.
3.x is compiled with netframework and 4.x is compiled with dotnet.
eventually 3.x will be dropped as netframework is no longer being updated,its been replaced with dotnet.

jksmurf
Offline
jksmurf's picture
Donator
Joined: 9 years
Last seen: 1 month

Sure, understood Blackbear199. The only thing I know for sure is that it did not work installing 4.2 on top of 3.2, did not work after uninstalling 3.2 then installing 4.2 and DID work when I installed 3.2 (back on top of 4.2 oddly and yes the log shows 3.2). If I can help troubleshoot it for you I can give it a go, but you're going to have to give me some direction.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 3 hours

maybe something changed in the latest installers.
far as i knew it was ok to have both as the actual executeables are in different folders in Porgram Files(x86)\WebGrab+Plus directory.
if it works with just one or the other installed go with whatever you prefer.
as i said above there is no difference functionally.

Edit:
i asked Jan and currently only linux supports having both installed.

jksmurf
Offline
jksmurf's picture
Donator
Joined: 9 years
Last seen: 1 month

OK Thanks. I did uninstall 3.X and installed 4.X as one of my Trials, but could not get that to work either.
I'd be happy with 4.X if it worked.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl