You are here

WebGrab+ gives config.xml error (even with the example file)!!!

5 posts / 0 new
Last post
golfzulu1
Offline
Donator
Joined: 11 months
Last seen: 6 months
WebGrab+ gives config.xml error (even with the example file)!!!

I was using WebGrab+ today and it was working fine. Then I made a minor edit to my config.xml file, saved it, and ran WebGrab+ again. I got an error message that it had an error at line 1313. There is no line 1313 in the config.xml file.

I tried using the example config.xml file. It gives the same error. Then I uninstalled WebGrab+ and re-installed it. I then tried running the example config.xml again, and I still get the error with line 1313. I tried deleting the config.xml file amd re-running, which produces an error that it can't find config.xml file. It seems that no matter what I throw at it, for a config.xml file, WebGrab+ doesn't like it!

This is installed on a PC running Windows 10. Attached are the config.xml and log files.

I am asking for help, please. I don't know what else to try.

If someone has seen this before, or has some clue what I could do to fix this, I would greatly appreciate it.

Thanks

golfzulu1
Offline
Donator
Joined: 11 months
Last seen: 6 months

I found the problem. I'm not going to delete this post, in case someone else experiences this, they won't have to spend hours trying to debug it.

The problem is that the guide.xml file got corrupted. Apparently Webgrab+ looks to see if there is a guide.xml file from a previous run, and tries to read it. That's why it had problems with line 1313, which was in guide.xml, not config.xml.

Took a long long time to figure it out. I was assuming that because the last thing I did was edit config.xml, that the problem was there. Still not sure how the guide.xml file got corrupted.

jbetbetbet
Offline
Donator
Joined: 1 year
Last seen: 6 months

" < filename >" *HINT* "Save AS"

golfzulu1
Offline
Donator
Joined: 11 months
Last seen: 6 months

Thank you jbetbetbet for taking the time to reply. I don't understand your reply. Are you suggesting I rename the guide.xml file?

I found a easier solution. Delete the guide.xml file, and when webgrab+ runs again, it will create a new one.

Thanks!

jbetbetbet
Offline
Donator
Joined: 1 year
Last seen: 6 months

Change guide.xml to whateveryouwanttosavethefileas.xml.
Leaving it as guide.xml will only overwrite previous grab.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl