You are here

Ubuntu 22.04 Ubuntu 22.04 only supports .net6 and higher

10 posts / 0 new
Last post
Ulli
Offline
Donator
Joined: 6 years
Last seen: 1 month
Ubuntu 22.04 Ubuntu 22.04 only supports .net6 and higher

Ubuntu 22.04 only supports .net6, how do I get webgrab++ with .net6 to function?

You must install or update .NET to run this application.

App: /wg++/bin.net/WebGrab+Plus.dll
Architecture: x64
Framework: 'Microsoft.NETCore.App', version '5.0.0' (x64)
.NET location: /usr/lib/dotnet/dotnet6-6.0.108/

The following frameworks were found:
6.0.8 at [/usr/lib/dotnet/dotnet6-6.0.108/shared/Microsoft.NETCore.App]

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 5 hours
Is the support helpful?
support us

Maybe you tried to install the dotnet5 sdk ? But to run WG++ you only need the dotnet5 runtime
Try this
sudo apt update
sudo apt install apt-transport-https
sudo apt install dotnet-runtime-5.0

Currently I have Ubuntu 20.04.4 LTS

dotnet --list-runtimes
Microsoft.AspNetCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

Ulli
Offline
Donator
Joined: 6 years
Last seen: 1 month

I have installed .net5, but only .net 6 is assumed, when I uninstall .net6, webgrab complains that I should install the latest .net6

apt install dotnet-runtime-5.0
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
dotnet-runtime-5.0 ist schon die neueste Version (5.0.17-1).
dotnet-runtime-5.0 wurde als manuell installiert festgelegt.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

dotnet --list-runtimes
Microsoft.AspNetCore.App 6.0.8 [/usr/lib/dotnet/dotnet6-6.0.108/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 6.0.8 [/usr/lib/dotnet/dotnet6-6.0.108/shared/Microsoft.NETCore.App]

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 16 hours

I have:
root@ubuntu:~# dotnet --info
.NET SDK (che rispecchia un qualsiasi file global.json):
Version: 6.0.300
Commit: 8473146e7d

Ambiente di runtime:
OS Name: ubuntu
OS Version: 20.04
OS Platform: Linux
RID: ubuntu.20.04-x64
Base Path: /usr/share/dotnet/sdk/6.0.300/

Host (useful for support):
Version: 6.0.5
Commit: 70ae3df4a6

.NET SDKs installed:
5.0.408 [/usr/share/dotnet/sdk]
6.0.300 [/usr/share/dotnet/sdk]

.NET runtimes installed:
Microsoft.AspNetCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

To install additional .NET runtimes or SDKs:
https://aka.ms/dotnet-download
root@ubuntu:~# dotnet --list-runtimes
Microsoft.AspNetCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
root@ubuntu:~# dotnet --list-sdks
5.0.408 [/usr/share/dotnet/sdk]
6.0.300 [/usr/share/dotnet/sdk]
root@ubuntu:~#

you need sdk net 5 check this link:
https://www.davidhayden.me/blog/install-net5-on-ubuntu-20-04

Ulli
Offline
Donator
Joined: 6 years
Last seen: 1 month

I have 22.04, and 22.04 supports only 6 and above. Upgrade to 22.04 then you have the same problem. https://docs.microsoft.com/en-us/dotnet/core/install/linux-ubuntu

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 16 hours

i think if you follow the link i posted for 20.04 will install it. Did you try it ?

yarafie
Offline
Donator
Joined: 10 months
Last seen: 2 months

Facing same problem did you resolve it?

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 5 hours
Is the support helpful?
support us

It can be done .. what I did :
I started with an old W10 computer .. that never had ubuntu on it !!
1st .. Enable WSl in add remove windows features
2nd .. download Ubuntu 20.04 from Microsoft store
3rd .. start ubuntu will install and create account
4rd .. sudu apt update
5th .. sudo apt upgrade
6th .. wget https://packages.microsoft.com/config/ubuntu/22.04/packages-microsoft-pr... -O packages-microsoft-prod.deb
sudo dpkg -i packages-microsoft-prod.deb
rm packages-microsoft-prod.deb
7th .. Now install dotnet 6.0 runtime (not sure if that is needed, but that is what I did)
sudo apt-get update && \
sudo apt-get install -y aspnetcore-runtime-6.0
8th .. Now same to install dotnet 5.0
sudo apt-get update && \
sudo apt-get install -y aspnetcore-runtime-5.0

Done !!
Check :
dotnet --list-runtimes
Microsoft.AspNetCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

WGMaker
Offline
WGMaker's picture
WG++ Team memberDonator
Joined: 10 years
Last seen: 5 hours
Is the support helpful?
support us

Probably the best alternative for Ubuntu 22 users .. try the dotnet 6 evaluation version of the program. It has the same functionality as the latest dotnet 5 evaluation version 4.2.4.6 . It's currently only tested on windows and ubuntu 20 !!
Get it from git .. https://github.com/SilentButeo2/webgrabplus-siteinipack/blob/master/eval...

yarafie
Offline
Donator
Joined: 10 months
Last seen: 2 months

Just tried the v5.0.0.1 version on Ubuntu 22.04.1 LTS (GNU/Linux 5.15.0-47-generic x86_64)

Works great with the default dotnet 6 version

Thanks

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl