You are here

Need help getting proper Urlshow element

4 posts / 0 new
Last post
khanhkronos
Offline
Joined: 4 years
Last seen: 1 year
Need help getting proper Urlshow element

Hi, I'm currently trying to make an .ini file for this website: https://www.redbyhbo.com/ 

I was able to grab pretty much everything in the schedule page, however I can't properly config WG to go to each show's program details page and grab additional info there. Here's what I have so far:

site {url=redbyhbo.com|timezone=UTC+06:00|maxdays=8|cultureinfo=en-US|charset=UTF-8|titlematchfactor=90|keepindexpage|episodesystem=onscreen}
urldate.format {datestring|dd/MM/yyyy}

url_index {url(debug)|https://www.redbyhbo.com/schedule/?date=|urldate|&country=all}
url_index.headers {method=POST}
url_index.headers {accept=text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8}
url_index.headers {customheader=Accept-Encoding=gzip, deflate, br}

index_showsplit.scrub {multi|<tr>||</tr>}

index_start.scrub {single|<td class="time">||</dt>}
index_temp_1.scrub {single|<a class="tooltip_trigger show_image cross_domain" href="http://webgrabplus.com/%7C%7C"}
index_title.scrub {single(separator=">"exclude=first|<a class=||<b}
index_urlshow {set(debug)|https://www.redbyhbo.com'index_temp_1'}
index_title.scrub {single(separator=">"exclude=first|<a class=||<b}
index_titleoriginal.scrub{single|r/>||</a>}

---

I want the urlshow to be displayed in the html.source.html page so that I can fetch the show info, but no matter what I've tried, somehow it refuses to load the program details page. Can I get some help to overcome this issue? Thanks in advance!

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 9 hours

As of 1 december 2017 I personally have a new policy, give support only to donators. So I wait you contribute or you wait someone do it for you (may be).

Attachments: 
khanhkronos
Offline
Joined: 4 years
Last seen: 1 year

@Blackbear199, thanks for your help. It really works! So does it mean to get index_urlshow to work, you'd always need to have both index_title and title.scrub at the very least?

@mat8861: I'm new to making WebGrab guides, and there's a Developer section in this forum, so I thought that someone here might be able to assist me, that's all. Certainly I don't expect anyone to help me do my "homework", if I wanted to I would have gone to the User Ini request section already. But it looks like you took time to make the guide too, so thank you for that!

Anyway, here's the site .ini file for anyone in need. For users in Myanmar, you may have to adjust the time back by 30 mins, so change the timezone settings to UTC+5:30 I guess. For everyone else, it should work fine out of the box. Enjoy!

ntbqn
Offline
Joined: 3 years
Last seen: 10 months

hi khanhkronos
update ini thank you
https://hboasia.com/HBO/en-vn/

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl