You are here

m.sms.cz - Czech republik - not working

7 posts / 0 new
Last post
ChromyMartin
Offline
Donator
Joined: 2 years
Last seen: 1 month
m.sms.cz - Czech republik - not working

Hello Webgrab team
I have problem with m.sms.cz ini. Before week working quick and nice. Yesterday i get without any change this message:

40/96 ) M.TV.SMS.CZ -- chan. (xmltv_id=Wau) -- mode Incremental

no robots data found
skipped robots check
i
error downloading page: The SSL connection could not be established.
Unable to update channel Wau
Generic syntax exception:
message:
no index page data received from Wau
unable to update channel, try again later
Existing guide data restored!

Any program from this ini not get epg.

I am on ubuntu 22.04 and dotnet core 5. All other ini working nice.

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 14 hours

That sound strange, i just runned and all looks fine.Do you have dotnet 5? I did install also version 6, before installing version 6 can you try update certificates for https with this:

dotnet dev-certs https
sudo -E dotnet dev-certs https -ep /usr/local/share/ca-certificates/aspnet/https.crt --format PEM
sudo update-ca-certificates

root@ubuntu:/home/ubuntu/Scrivania/.wg++# dotnet --info
.NET SDK (che rispecchia un qualsiasi file global.json):
Version: 6.0.300
Commit: 8473146e7d

Ambiente di runtime:
OS Name: ubuntu
OS Version: 20.04
OS Platform: Linux
RID: ubuntu.20.04-x64
Base Path: /usr/share/dotnet/sdk/6.0.300/

Host (useful for support):
Version: 6.0.5
Commit: 70ae3df4a6

.NET SDKs installed:
5.0.408 [/usr/share/dotnet/sdk]
6.0.300 [/usr/share/dotnet/sdk]

.NET runtimes installed:
Microsoft.AspNetCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.AspNetCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 5.0.17 [/usr/share/dotnet/shared/Microsoft.NETCore.App]
Microsoft.NETCore.App 6.0.5 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

To install additional .NET runtimes or SDKs:
https://aka.ms/dotnet-download

ChromyMartin
Offline
Donator
Joined: 2 years
Last seen: 1 month

Thanks for your help. But your fix not help.

streamer@Streamer:~$ dotnet --info
.NET SDK (reflecting any global.json):
Version: 5.0.408
Commit: da985e2a23

Runtime Environment:
OS Name: ubuntu
OS Version: 22.04
OS Platform: Linux
RID: linux-x64
Base Path: /snap/dotnet-sdk/167/sdk/5.0.408/

Host (useful for support):
Version: 5.0.17
Commit: 6a98414363

.NET SDKs installed:
5.0.408 [/snap/dotnet-sdk/167/sdk]

.NET runtimes installed:
Microsoft.AspNetCore.App 5.0.17 [/snap/dotnet-sdk/167/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 5.0.17 [/snap/dotnet-sdk/167/shared/Microsoft.NETCore.App]

To install additional .NET runtimes or SDKs:
https://aka.ms/dotnet-download
streamer@Streamer:~$

Can you describe how instal dot net on new system?

If i make install dont net 6 an 5 together - i get error message with instalation of the bad revision of dot net.

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 14 hours

originally i installed dotnet 5, because last version use dotnet 6 i followed microsoft advice here for sdk install:
https://docs.microsoft.com/it-it/dotnet/core/install/linux-ubuntu
Just to make sure, did you run the command to update https certificates ?

ChromyMartin
Offline
Donator
Joined: 2 years
Last seen: 1 month

hi
Yes i install:
dotnet dev-certs https
sudo -E dotnet dev-certs https -ep /usr/local/share/ca-certificates/aspnet/https.crt --format PEM
sudo update-ca-certificates

What variant of installation you use?

In alternativa, installare .NET con Snap.
In alternativa, installare .NET con install-dotnet script.
Installare manualmente .NET

I use SNAP install

Here is also note about ssl

When .NET is installed through Snap, it's possible that on some distros the .NET TLS/SSL certificates may not be found and you may receive an error during restore:

Bash

Copy
Processing post-creation actions...
Running 'dotnet restore' on /home/myhome/test/test.csproj...
Restoring packages for /home/myhome/test/test.csproj...
/snap/dotnet-sdk/27/sdk/2.2.103/NuGet.targets(114,5): error : Unable to load the service index for source https://api.nuget.org/v3/index.json. [/home/myhome/test/test.csproj]
/snap/dotnet-sdk/27/sdk/2.2.103/NuGet.targets(114,5): error : The SSL connection could not be established, see inner exception. [/home/myhome/test/test.csproj]
/snap/dotnet-sdk/27/sdk/2.2.103/NuGet.targets(114,5): error : The remote certificate is invalid according to the validation procedure. [/home/myhome/test/test.csproj]
To resolve this problem, set a few environment variables:

Bash

Copy
export SSL_CERT_FILE=[path-to-certificate-file]
export SSL_CERT_DIR=/dev/null
The certificate location will vary by distro. Here are the locations for the distros where the issue has been experienced.

Distribution Location
Fedora /etc/pki/ca-trust/extracted/pem/tls-ca-bundle.pem
OpenSUSE /etc/ssl/ca-bundle.pem
Solus /etc/ssl/certs/ca-certificates.crt

ubuntu have same certificate like solus but thi alsno not help..

ChromyMartin
Offline
Donator
Joined: 2 years
Last seen: 1 month

Hi
Mistake o my side.

bad dot net isntalation with snap

In new wirtual mashine on ubuntu 22.04

manualy install dot net according manual:
https://www.how2shout.com/linux/how-to-install-net-core-dotnet-on-ubuntu...

and libssl bad instaliton. repare according this manual:
wget "http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0..."
wget "http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0-dev_1..."
sudo dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.10_amd64.deb
sudo dpkg -i libssl1.0-dev_1.0.2n-1ubuntu5.10_amd64.deb

and woalaaaa
SMS.cz working. Sorry for waste of your time.

Thanks again Martin

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 14 hours

No problem, good you solved

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl