You are here

How to add new/live to end of title instead of *

6 posts / 0 new
Last post
sparklesunshine
Offline
Donator
Joined: 2 years
Last seen: 8 months
How to add new/live to end of title instead of *

In the tvguide.com siteini - if it is a new program episode that is airing it will add a * to the end of the title.

How do you change the * so it says new instead. Also how do you change the font type of the word new so it looks different from the rest of the title.

I'd also like to know how you can add live to the end of the show title if the show is live (assuming this is flag that this siteini can detect)

I can see this siteini adds new live repeat to the end of the description but would be nice to have just new and maybe live in a different font type at the end of the show title.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

replace these lines..

index_title.modify {addend('index_temp_5'=="4")| *}
title.modify {addend('temp_5'=="4")| *}

with

index_title.modify {addend('index_temp_5'=="4")| New}
index_title.modify {addend('index_temp_5'=="1")| (live)}

title.modify {addend('temp_5'=="4")| New}
title.modify {addend('index_temp_5'=="1")| (live)}

you can change New and (live) to however u want it to appear like all capitals or whatever.
u cannot change the type font.

sparklesunshine
Offline
Donator
Joined: 2 years
Last seen: 8 months
Blackbear199 wrote:

replace these lines..
index_title.modify {addend('index_temp_5'=="4")| *}
title.modify {addend('temp_5'=="4")| *}
with
index_title.modify {addend('index_temp_5'=="4")| New}
index_title.modify {addend('index_temp_5'=="1")| (live)}
title.modify {addend('temp_5'=="4")| New}
title.modify {addend('index_temp_5'=="1")| (live)}
you can change New and (live) to however u want it to appear like all capitals or whatever.
u cannot change the type font.

That's what I thought but when I tried I still got a * although I did just do an incremental update - I can try with a force update later.

Also when I tried that every description that had (cc) at the end suddenly had an extra (c) after (cc) so it displayed (cc) (c) which I thought was strange

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 7 years
Last seen: 3 hours

it was a bit more complicated than i thought.
Live and New are added to title and not to the end of the description,(cc) and (repeat) still are.

the (c) your referring to was added by webgrab i think because the above code messed things up,if you remember when webgrab ran you probably seen something like iiiiiiiinnncccncncncncncncncncncncncccccccccccnnnnnnnnn( a mix of c's and n's)
this is webgrab doing corrections caused by the changes.

the first time you run the new ini in incrimental mode you are going to see a ton of corrections,this is because the title now has Live and New added to it and webgrab will think it changed.
disregard these,the second time it updates it should run and update normally.

Attachments: 
sparklesunshine
Offline
Donator
Joined: 2 years
Last seen: 8 months
Blackbear199 wrote:

it was a bit more complicated than i thought.
Live and New are added to title and not to the end of the description,(cc) and (repeat) still are.
the (c) your referring to was added by webgrab i think because the above code messed things up,if you remember when webgrab ran you probably seen something like iiiiiiiinnncccncncncncncncncncncncncccccccccccnnnnnnnnn( a mix of c's and n's)
this is webgrab doing corrections caused by the changes.
the first time you run the new ini in incrimental mode you are going to see a ton of corrections,this is because the title now has Live and New added to it and webgrab will think it changed.
disregard these,the second time it updates it should run and update normally.

Thanks for the updated siteini - I'll test it out over the weekend

sparklesunshine
Offline
Donator
Joined: 2 years
Last seen: 8 months
Blackbear199 wrote:

it was a bit more complicated than i thought.
Live and New are added to title and not to the end of the description,(cc) and (repeat) still are.
the (c) your referring to was added by webgrab i think because the above code messed things up,if you remember when webgrab ran you probably seen something like iiiiiiiinnncccncncncncncncncncncncncccccccccccnnnnnnnnn( a mix of c's and n's)
this is webgrab doing corrections caused by the changes.
the first time you run the new ini in incrimental mode you are going to see a ton of corrections,this is because the title now has Live and New added to it and webgrab will think it changed.
disregard these,the second time it updates it should run and update normally.

It works thank you - the pulling of the index takes a lot longer though. Is there anyway to speed this up?

edit - saw your post about keepindexpage

For now i'll have to create separate config files in order to enable it else it takes hours to pull anything.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl