You are here

ConfigMaker tool for multiple configurations

42 posts / 0 new
Last post
shax
Offline
Donator
Joined: 3 years
Last seen: 1 year
ConfigMaker tool for multiple configurations

Like many others I want to have EPG on my satellite receiver and WebGrab++ seemed like great tool.
Since I'm also lazy I don't want to do all the hard work of channel mapping, editing configurations, etc.. over and over again.
Modifying/maintaining one "grab" configuration is not that much of a deal, but problems rise when you have multiple configurations to run. Constantly copy/pasting site keys, updating inis & xmls, checking paths. Unacceptable.
What I also learned was that many others have same problems.

So I decided to create (hopefully) simple tool to do all the heavy lifting for me and other people with same problems.
Minimum requirements are Windows with .NET 4.6.2 or greater installed. Other OS not supported.
Application is open sourced and available at

https://github.com/shaxxx/EPGUtils/releases

While app is simple to use you'll probably have hard time figuring out how to use the app, and what it does without some kind of tutorial, manual. I'll try to create something when times allows me.

Cheers.

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 1 day

Thanks, great tool !!

Jean0987654321
Offline
Donator
Joined: 3 years
Last seen: 1 year

This is a pretty damn good tool. Sometimes I feel the documentation section of this site is like reading Chinese but this makes grabbing Webgrabplus easier...

Thanks

shax
Offline
Donator
Joined: 3 years
Last seen: 1 year

I guess it takes some time to guess how app works and what it does.
I was able to find some time to create some kind of tutorial/overview to get you started.
https://www.youtube.com/watch?v=Izgt8A808zU&list=PLX4MdIIptHxiA5iq6KB0P2...

Jean0987654321
Offline
Donator
Joined: 3 years
Last seen: 1 year

I wasn't talking about your tool but the site doc for webgrabplus
http://www.webgrabplus.com/documentation

shax
Offline
Donator
Joined: 3 years
Last seen: 1 year

I know, first sentence is referring to my app :)

shax
Offline
Donator
Joined: 3 years
Last seen: 1 year
sagona
Offline
Donator
Joined: 4 years
Last seen: 1 year

Very nice app can praise you for the work

jonnyp
Offline
Donator
Joined: 2 years
Last seen: 2 years

This is a really great help for putting together channels lists from different ini files...thanks.

franky64
Offline
Has donated long time ago
Joined: 1 year
Last seen: 1 year

I can not get the Config Maker to work. latest windows 11 , latest dot.net , several PCs tested, always the same

Failed to create user configuration.There is an error in XML document

shax
Offline
Donator
Joined: 3 years
Last seen: 1 year

Can you provide the screenshot of the error and the configuration files (remove license info)?

shax
Offline
Donator
Joined: 3 years
Last seen: 1 year

Can you provide the screenshot of the error and the configuration files (remove license info)?

shax
Offline
Donator
Joined: 3 years
Last seen: 1 year

Can you provide the screenshot of the error and the configuration files (remove license info)?

shax
Offline
Donator
Joined: 3 years
Last seen: 1 year

Can you provide the screenshot of the error and the configuration files (remove license info)?

franky64
Offline
Has donated long time ago
Joined: 1 year
Last seen: 1 year

I created a test xml and put it in the config folder, it reads it but it doesn't seem to use it, I understood that you can create a new config file with the tool, but that doesn't work either.

Attachments: 
azman
Offline
Donator
Joined: 3 years
Last seen: 1 week

@franky64

The problem is two empty files in siteini.pack/Canada/
Delete
sportsnet.ca.ini
sportsnet.ca.channels.xml
After this procedure, EPG_ConfigMaker will run and create new configurations.

@mat8861 please remove these files from the directory or post the correct versions.
Currently these files have no entries they are empty inside zero lines of code.

franky64
Offline
Has donated long time ago
Joined: 1 year
Last seen: 1 year

OMG , now it works!

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 1 day
azman wrote:

@franky64
The problem is two empty files in siteini.pack/Canada/
Delete
sportsnet.ca.ini
sportsnet.ca.channels.xml
After this procedure, EPG_ConfigMaker will run and create new configurations.
@mat8861 please remove these files from the directory or post the correct versions.
Currently these files have no entries they are empty inside zero lines of code.

Removed also because are available in other siteinis

gortshak2
Offline
Donator
Joined: 1 year
Last seen: 1 year

Hello. I did everything as in the video, but when I try to execute the configuration, an error appears. Help decide.

panaxtream
Offline
Donator
Joined: 5 years
Last seen: 5 months

i have this message:

failed to create user configuration, there is an error in xml document (0, 0)

I am not able to add or create or edit the current configurations.

I have reinstalled all versions and different computers and the same error is displayed.

Attachments: 
ylliricon
Offline
Donator
Joined: 2 years
Last seen: 5 months

Hi everyone.

I have used ConfigMaker before without any issues, but installed it now on windows 11 and for some reason the "Run Configuration" button is missing! any idea how to fix this?

Cheers

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 3 min

are you using latest 2.2.0?
i dont use it but just downloaded it and its fine on win 11 for me(run Configuration button is there)

ylliricon
Offline
Donator
Joined: 2 years
Last seen: 5 months

No i am using 0.2.1.0, I also downloaded the latest version 2.2.0 but for some reason it does not download the siteini files or starts!

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 3 min

for me on the first run there was a popup asking this,i clicked no as i didnt want to download them but there is also a button for this after it opens.

Attachments: 
ylliricon
Offline
Donator
Joined: 2 years
Last seen: 5 months

Thank you for the suggestion I just tried that and i got an error "Can't continue without sitein.pack. Application will exit."

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 3 min

copy the siteini.pack folder from 2.1.0 directory to your 2.2.0 directory then start it.

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 3 min

btw i dont see a need for this.
someone should make a request on git for it to check users AppData/Local/WebGrab+Plus directory for the siteini.pack or have a option to select its location.
i dont see why it should have to be downloaded again if it already exists.

ylliricon
Offline
Donator
Joined: 2 years
Last seen: 5 months

So for some reason now on the latest version it does download siteini.pack! but the "Run Configuration" button is still now there!

There is the other "run" button, "Run All Configurations" when i run that one i get an error saying "failed to run configuration. The system cannot find the file specified"

You are right we should not need to download siteini.pack if it's are already there, although this is a free software i wish it would be made more user-friendly :)

just wondering does the ConfigMaker need to be in the same directory as webgrab++

Thank you for your help

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 3 min

no idea what to suggest.
there is another option provided by another user awhile ago..
https://manyplay.de/xmlgrabplus-for-windows-and-osx-and-linux64/

ylliricon
Offline
Donator
Joined: 2 years
Last seen: 5 months

Thank you for your help and suggestions I will go through the link you provided hopefully will get it working again!

May I ask you one more question; I have donated yesterday to Webgrab++ for a Donator licence it still has not been updated under my account any idea how long it i will take for it to be activated, I have also emailed WebGrab++ and also Included my Username on the payment

Regards

Blackbear199
Online
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 3 min

i just checked and your good,you have your badge.

Donator status is VALID until 20/04/2024
Last access 21/04/2023 07:52

ylliricon
Offline
Donator
Joined: 2 years
Last seen: 5 months

Thank you for checking :)

ARTellez
Offline
Donator
Joined: 1 year
Last seen: 5 days
panaxtream wrote:

i have this message:
failed to create user configuration, there is an error in xml document (0, 0)
I am not able to add or create or edit the current configurations.
I have reinstalled all versions and different computers and the same error is displayed.

In the downloaded SiteIniPack you have to delete the following files:

In Australia folder:
fetchtv.com.au.channels.xml
fetchtv.com.au.ini

In UK folder:
freesat.co.uk.channels.xml
freesat.co.uk.HD.channels.xml
freesat.co.uk.ini

ylliricon
Offline
Donator
Joined: 2 years
Last seen: 5 months

I have figured out why i was having issues with the “Run Configuration” button missing!

When i installed WebGrab++ i changed the default folder where it gets installed, I am guessing ConfigMaker only looks for the files on the Default Installation Folder.

panaxtream
Offline
Donator
Joined: 5 years
Last seen: 5 months

Many thans, solved

slaserx
Offline
Has donated long time ago
Joined: 1 year
Last seen: 12 hours

Good job

shax
Offline
Donator
Joined: 3 years
Last seen: 1 year

I had some time today and published new 0.2.4.0 version.
Too many people is bugging me on multiple platforms because invalid xml files in siteini.pack
New version simply ignores invalid sites.

Download from https://github.com/shaxxx/EPGUtils/releases

To reflect on some questions: no app will not ask you to re-download siteini.pack if it exists in the working folder.
There is no installation. Where's the working folder you may ask?
By default it's where ConfigMaker.exe is, you can change it and other settings in ConfigMaker.exe.config.
Default values are pretty reasonable for vast majority, if you're advanced then go ahead and play with settings.

And if you want the app to be more user friendlier, go ahead and do something about it.

mat8861
Offline
WG++ Team memberDonator
Joined: 8 years
Last seen: 1 day
shax wrote:

I had some time today and published new 0.2.4.0 version.
Too many people is bugging me on multiple platforms because invalid xml files in siteini.pack
New version simply ignores invalid sites.
Download from https://github.com/shaxxx/EPGUtils/releases
To reflect on some questions: no app will not ask you to re-download siteini.pack if it exists in the working folder.
There is no installation. Where's the working folder you may ask?
By default it's where ConfigMaker.exe is, you can change it and other settings in ConfigMaker.exe.config.
Default values are pretty reasonable for vast majority, if you're advanced then go ahead and play with settings.
And if you want the app to be more user friendlier, go ahead and do something about it.

Great !

highlander
Offline
Donator
Joined: 6 months
Last seen: 2 months

Hello Shax,

the configurator is great.
It harmonizes very well with WebGeab V3.3. For your information, with the new version WebGrab5... it doesn't work under Windows 11. It's not a problem because it works very well with V3.3.

Greetings highlander

ARTellez
Offline
Donator
Joined: 1 year
Last seen: 5 days

Configurator works OK under Windows 11, which version are You using? 0.2.4.0 ignore the errors in SiteIniPack files.
Version 0.2.2.0 needs to replace some files with the attached ones after updating SiteIniPack or will get error if you try to create a new configuration

Hauzz
Offline
Hauzz's picture
Donator
Joined: 10 months
Last seen: 2 weeks

Hi guys, I'm having trouble to get telenet.tv.be in Configmaker. When I select Belgium in Configmaker and look for telenet.tv, there is no entry. In the configurations\siteini.pack\Belgium directory there are three files with telenet.tv.be in the name present. telenet.tv.be.channels.antwerpen.xml, telenet.tv.be.channels.brussels.xml and telenet.tv.be.
Still in Configmaker not visible. Not even when I change the file name from telenet.tv.be.channels.antwerpen.xml in telenet.tv.be.channels.xml.
How do I make this site visible in Configmaker?
Thanks

Found it!
I've changed the file name telenet.tv.be.channels.antwerpen.xml in the configurations\siteini.pack\Belgium directory.
I should have changed it in the siteini.pack directory of the working directory cause Configmaker reads it from there. Now telenet.tv is visible and I can select channels.

ARTellez
Offline
Donator
Joined: 1 year
Last seen: 5 days

Configmaker doesn't support multiple channels listing. In SiteIniPack there are 2: Antwerpen and Brussels, so Configmaker ignores the site ini.
To solve this you need to copy any one of them (or any other you generate) to "telenet.tv.be.channels.xml" this file is the one that Configmaker will use

If You want to generare 2 configs for 2 different regions, generate the first one as above and then copy de second channels listing to the file "telenet.tv.be.channels.xml" and generate your second config. Once created, individual files will be copied to SiteIniUser folder in each config.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl