You are here

tv.mail.ru incorrect ime

2 posts / 0 new
Last post
bl00dy
Offline
Donator
Joined: 7 months
Last seen: 2 months
tv.mail.ru incorrect ime

Hello,

There is a problem with timing.

for example channel 2209. On a web page time is correct, but on EPG is time shift -03:00.

Ed

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 11 hours

what you see on the site and what the actual epg xml file says have nothing to do with each other.

a brief explaination is here
http://webgrabplus.com/faq#faq_1238

epg times can be in 3 different formats
UTC ==> +0000
local time of the site ===> time offset of site used
local time of the user ===> time offset of the user

this ine uses local time of the site(tahst why you see +0300)

when you view the epg with your software and the time is not correct then you have another issue.
your software should automatically calculate the correct local time for the user using the time offset from the epg xml and the actual users time offset.

example..
my local time is UTC-0400
epg xml
start="20220217183000 +0300"

my epg software would calculate..
epg time offset ==========> +0300
users local time offset ==> -0400

it would substract 7 hours from the start time,so what i would actually see for a start time is..
2022-02-17 18:30 - 0700 ===> 2022-02-17 11:30

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl