You are here

tvtv.us and tvtv.ca URL changes

68 posts / 0 new
Last post
5LH3H
Offline
Joined: 1 year
Last seen: 5 months
tvtv.us and tvtv.ca URL changes

There has been recent changes to the URL's at tvtv.us and tvtv.ca

e.g.

Old URL
https://tvtv.ca/qc/montreal/lu5931D
https://tvtv.us/ny/buffalo/14201/lu2381D

New URL
https://tvtv.ca/qc/montreal/luCAN-0004980-X
https://tvtv.us/ny/buffalo/14201/luUSA-DITV501-DEFAULT

As we can see the site code has changed from a numerical value to CAN-xxxxx-X.

I believe the site.ini files for both tvtv.us and tvtv.ca require changes to the regex, to help identify this URL change so the entry used in the WebGrab config (site_id) can continue to function.

Fallito
Offline
Donator
Joined: 5 years
Last seen: 3 months

Yes, I was trying to regenerate my locals channels today and was not able to.

japangelo
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

someone figured this out? can't create new channel lists at all

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

be patient

Attachments: 
japangelo
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

ok mat we'll be :) let us know when you have any news

BeChan
Offline
BeChan's picture
Donator
Joined: 2 years
Last seen: 5 hours

canada com with same id is fine

BeChan
Offline
BeChan's picture
Donator
Joined: 2 years
Last seen: 5 hours
japangelo wrote:

ok mat we'll be :) let us know when you have any news

Attachments: 
japangelo
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

hi, thank you for updating the ini file. I was able to create the toronto providers list and got my channel list as well. Unfortunately im not able to create a providers list for the city of Edmonton. I tried the postal code T5H2E5, which works in the website, but I get the error:

Generic syntax exception:
[Critical] message:
[Error ] no index page data received from tvtv
[Error ] unable to update channel, try again later
[ Info ] Existing guide data restored!

I tried a few other postal codes from Edmonton but no luck. Are you able to create a providers list for the pc T5H2E5 or others from this city?

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

new one, fixed provider scrub...edmonton ok ;)

Attachments: 
japangelo
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

thank you so much mat :)

Min
Offline
Donator
Joined: 3 years
Last seen: 4 months

Thank you!

BeChan
Offline
BeChan's picture
Donator
Joined: 2 years
Last seen: 5 hours
mat8861 wrote:

new one, fixed provider scrub...edmonton ok ;)

Great team and good job
Many thanks Mat

dariofol
Offline
Donator
Joined: 3 years
Last seen: 1 month

My friends for the tvtv.us? there's also a new ini file?

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min
dariofol
Offline
Donator
Joined: 3 years
Last seen: 1 month

for encrypt ini its possible decrypt in some way and using in a old webgrab version?
I using my ini file until yesterday

bluzee
Offline
Donator
Joined: 1 year
Last seen: 1 month
dariofol wrote:

for encrypt ini its possible decrypt in some way and using in a old webgrab version?
I using my ini file until yesterday

You must buy donor license.

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min
bluzee wrote:

dariofol wrote:
for encrypt ini its possible decrypt in some way and using in a old webgrab version?
I using my ini file until yesterday

You must buy donor license.

Up to you...
Let me add : this place has been free for years without everyone doing a small contribute. A contribute either to keep this forum up, pay for the server, the dns license, developement and software upgrades, including all the siteini update/upgrade. It all started for fun with very limited costs. Time has changed and without a very small contribution, you will soon click on this url and find "Error 404 Not found".
Bye

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

I have added the new site ini file but still unable to update any of my epg or create channels lists from new url. Can someone please send a sample config file for https://tvtv.us/ny/new-york/luUSA-SLNG501-DEFAULT that I can use as a refrence and also do I need to redo all my xml configs because its still got the old id or can I just edit the existing one

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

Attached

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

Thx and yes I have loaded it already and followed the remarks to create a channel list with no luck. could you please send me a sample config of what you used to create that xml

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

it's all in the remarks of siteini...if you have lineup just run c2-USA-SLNG501-DEFAULT and in the channel line add it to siteid filed.

Attachments: 
rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

https://tvtv.us/ny/new-york/luUSA-DISH501-DEFAULT this is another I need as well as a few others so if you can please send a sample config for that one to reference it would be greatly appreciated

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

just set in config as the picture....replace with USA-DISH501-DEFAULT the sling lineup and wait...

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

I tried a few time excatly like the pic shows and this is what happens

Group (0) :
update requested for - 1 - out of - 1 - channels for 7 day(s)
( 1/1 ) TVTV.US -- chan. (xmltv_id=tvtv) -- mode Incremental
iiiiiii
Unable to update channel tvtv
Generic syntax exception:
message:
no index page data received from tvtv
unable to update channel, try again later
No guide data to restore

Job finished at 21/01/2022 18:54:29 done in 4s

and this is how I entered it

c2-USA-SLNG501-DEFAULT
tvtv

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

sorry like this
c2-USA-SLNG501-DEFAULT
tvtv

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

this is with more elements actor role, producer, presenter,etc etc

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min
rbyw1203 wrote:

sorry like this
c2-USA-SLNG501-DEFAULT
tvtv

yes like that....xmltv_id can be anything

Attachments: 
rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

Group (0) :
update requested for - 1 - out of - 1 - channels for 1 day(s)
( 1/1 ) TVTV.US -- chan. (xmltv_id=tvtv) -- mode Incremental
i
Unable to update channel tvtv
Generic syntax exception:
message:
no index page data received from tvtv
unable to update channel, try again later
Existing guide data restored!

Job finished at 21/01/2022 19:46:15 done in 1s

and this is what I used

update>c2-USA-DISH501-DEFAULTtvtv

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

wow something definitly screwed up so I updated one my system to newest version and its saying my lisc expired and wont even download the xml you sent me it says skipped because the site.ini is encrypted. my other one the older version will download the xml file you sent and says lisc will expire on 03/05 which is correct but it just wont pull a new channel list

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

the c2 goes only in field update see picture.
Run update license change to "f" the text that says: To force a license update; replace this text with the letter f
For skipped siteini encrypted see http://webgrabplus.com/faq#faq_5419

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

I have tried and done everything you posted and sent me and I am stil getting the same errors and I still need a few xml to finish my list

BeChan
Offline
BeChan's picture
Donator
Joined: 2 years
Last seen: 5 hours

check tvtv.us.robots
only 2 line
User-agent: *
User-agent: WebGrab+Plus

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

yes its like that

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

it is USA-DISH501-DEFAULT

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

I changed it and still getting same error

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

sorry i didn't see it before, but upgrade wg++ to latest
https://github.com/SilentButeo2/webgrabplus-siteinipack/tree/master/eval...
also it doen't look like mono is installed...is it ?

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

yes I did that and it says I have a custom lisc but its expired and also still skipped site ini encrypted and I just reinstalled it on a windows machine

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

yes I did that and it says I have a custom lisc but its expired and also still skipped site ini encrypted and I just reinstalled it on a windows machine

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

again only having problems creating cgannel lists I can use xml that you created already so it would be great if all the ones from pc-10001 were posted and not just sling

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

Please have a look to the picture and comments i posted here, for tvtv.us is the same
http://www.webgrabplus.com/comment/28148#comment-28148

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

I Give up I have copied everything from there as well and nothing works. All my other ones work just fine its only the tvtv.us that dont since the change. I can pull data no problems from xml files that were sent to me it just wont create any channel lists. So if anyone has been able to create channel list I would be much appreciated if they could share them. Thank you

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min
rbyw1203 wrote:

I Give up I have copied everything from there as well and nothing works. All my other ones work just fine its only the tvtv.us that dont since the change. I can pull data no problems from xml files that were sent to me it just wont create any channel lists. So if anyone has been able to create channel list I would be much appreciated if they could share them. Thank you

if you post your zip code, city or lineup i will show you how to do it.

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

https://tvtv.us/ca/los-angeles/luUSA-CA66511-X

AT&T U-verse TV - Los Angeles
Los Angeles, California

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

The problem you have is due to:
1. the sign "&" that cannot be used in any field of configuration. You could use it as decoded "&_amp_;"(no underscore) but since is a visual aspect of the file name it's easier to use another character.
2. the name of the c1 and c2 has a restricted lenght so cannot be pretty long.
see photo

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

Group (0) :
update requested for - 1 - out of - 1 - channels for 1 day(s)
( 1/1 ) TVTV.US -- chan. (xmltv_id=att) -- mode Incremental
i
Unable to update channel att
Generic syntax exception:
message:
no index page data received from att
unable to update channel, try again later
Existing guide data restored!

I dont get it always the same error

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

if you don't post your config (remove license line) i do not know what are you trying to do.

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

Here is the config file and error log

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 6 years
Last seen: 3 days

update webgrab
cx- channel update mode wasnt added until version 3.1.8 release..

05/05/2021
Version 3.1.8 beta
---------------------------------------------------------------------------------------------
- (3.1.7.4) removed : xmltv test project
removed : reference System.Web and System.Web.extentions = depreciated
changed : the system.web members htmldecode and urldecode to webutitlities namespace
- (3.1.7.3) changed : in license custom license remains inactive when no valid donator_license
- (3.1.7.2) added : option to specify a channellist name , e.g. c3-Cannada-East
- (3.1.7.1) added : auto channelcreation option for multi step channel creation , specified with c1, c2 etc in channel update

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

I also tried on newest version released 15hrs ago and it keeps saying skipped- encrypted ini. And I did the wget operation of the ini file instead of transfer thru ftp. I tried a few other ones I use on the newest version and they work fine. Its only tvtv.us giving me the issue

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 20 min

follow Blackbear suggestion, run siteini.pack update or read the the FAQ for the "skipped encrypted siteini" here http://www.webgrabplus.com/faq#faq_5419
Attached your list

rbyw1203
Offline
Donator
Joined: 1 year
Last seen: 2 days

So it looks like its saying my lisc has expired which is not true. But it says in log not able to encrypt because of lisc

Pages

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl